← Back to overview
May 25, 2010 · Continuous Integration TeamCity

TeamCity 5.1 Upgrade: The requested class "net.sourceforge.jtds.jdbc.Driver" not found.

When upgrading TeamCity to version 5.1 (with .NET 4.0 support!), I encountered the following issue:

The requested class "net.sourceforge.jtds.jdbc.Driver" not found.

You’ll get this issue when you use a MSSQL databases. But I guess it will be the same for Oracle, MySQL, Sybase…
The reason for this issue is a breaking change in the directory structure. The database drivers should be located in an other directory.

Documentation: Since TeamCity 5.1, put the driver jar(s) into /lib/jdbc directory (create it if necessary).

Required steps to solve the issue:

  1. Run TeamCity and it should crash (but it will write the current data directory to the log file)
  2. Find your current data directory: Go to your TeamCity directory and open teamcity-server.log under logs.
  3. You should get something like this (this is your data directory):

    [2010-05-25 12:50:25,682] INFO – dServer.serverSide.ServerPaths – TeamCity data directory: D:/Continuous Integration/TeamCity Configuration/

  4. Browse to that path and create a directory named lib and under lib you should create the directory jdbc

  5. Download the jtds package
  6. Extract it and copy jtds-1.2.5.jar to your jdbc directory.
  7. Restart the TeamCity Web Service

This should have solved your upgrade issue.

Enjoy

  • LinkedIn
  • Tumblr
  • Reddit
  • Google+
  • Pinterest
  • Pocket
Comments powered by Disqus